Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › no rule to make target

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #23875

    Bas

    hi,

    i try “AppPlayground” to compile to “Felgo Desktop (Qt 5.13.2 clang)”

    but i get an error when i press play or run qmake.

    No rule to make target ‘AppPlayground’. Stop.

     

    other builds are working fine, i reinstalled Felgo on mac, but that did not work.

    what can i check or do to make it work again?

    greetz,

    Bas

    #23883

    Alex
    Felgo Team

    Hi Bas,

    can you send us your version of macOS and Xcode? With “other builds are working fine” do you mean other projects or other build targets like iOS or Android? Also is there any other compile log output that might give a hint to the source of the issue?

    Best,
    Alex

    #23887

    Bas

    <h3>other builds: ios / android</h3>
    XCODE : Version 12.0.1 (12A7300)

    MACos: 10.15.7 (19H2)

     

    ——————————————————————

    15:22:24: Running steps for project TPCursist…

    15:22:24: Starting: “/Users/baslentfert/Felgo/Felgo/clang_64/bin/qmake” /Users/baslentfert/qtprojects/TPCursist/TPCursist.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug

    15:22:25: The process “/Users/baslentfert/Felgo/Felgo/clang_64/bin/qmake” exited normally.

    15:22:25: Starting: “/usr/bin/make” -f /Users/baslentfert/qtprojects/build-TPCursist-Felgo_Desktop_Qt_5_13_2_clang-Debug/Makefile qmake_all

    make: *** No rule to make target `TPCursist’. Stop.

    The platform SDK has been changed from version 10.15.4 to version 10.15.6.

    This requires a fresh build. Please wipe the build directory completely,

    including any .qmake.stash and .qmake.cache files generated by qmake.

    /Users/baslentfert/Felgo/Felgo/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^. Stop.

    15:22:25: The process “/usr/bin/make” exited with code 2.

    Error while building/deploying project TPCursist (kit: Felgo Desktop (Qt 5.13.2 clang))

    When executing step “qmake”

    15:22:25: Elapsed time: 00:01.

    #23888

    Bas

    The platform SDK has been changed from version 10.15.4 to version 10.15.6.

    this is probably causing the error.

    #23889

    Bas

    ok i got it working again

    i add

        QMAKE_MAC_SDK = macosx10.15
    
    

    in the pro file

    #24062

    Bas

    having same thing again

    mac os 10.15.7

    xcode version: 12.2 (12B45b)

    the fix does not work

    gr,

    Bas

    #24067

    Bas

    Updated Xcode and re-installed Felgo, still the same result

    :-1: error: No rule to make target `AppPlayground’. Stop.

     

    some suggestions would be nice!

    Thanx in advance,

    Bas Lentfert

    #24068

    Bas

    i am going to re install xcode, maybe that helps

    IOS and Android works fine btw. but i need to compile to desktop macos

    #24069

    Bas

    I created a new project, bu still the same : no rule to make target.

    #24070

    Bas

    :-1: warning: “/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang” is used by qmake, but “/Users/baslentfert/Felgo/Qt Creator.app/Contents/Resources/libexec/clang/bin/clang” is configured in the kit.
    Please update your kit (Felgo Desktop (Qt 5.13.2 clang)) or choose a mkspec for qmake that matches your target environment better.

     

    i am not shure what this means?

    #24075

    Alex
    Felgo Team

    Hi Bas,

    I will raise this to one of our platform specialists, I hope to get an answer soon.

    Best,
    Alex

    #24076

    Alex
    Felgo Team

    In the meantime, could you try to delete your qmake.stash file (you should find it in your project or home folder). If that does not help, you can check if there are any manual kits set up in Qt Creator that might not be correct.

    Best,
    Alex

    #24077

    Bas

    hi Alex,

    i re-installed felgo and xcode, and i checked for the qmake.stash file.

    but i ccould not find a qmake.stash file.

    I also experimented with webasm, could that have todo with it (but that was before I re installed felgo and xcode)?

    #24087

    Bas

    sorry i found a qmake.stash file in my user directory root.

    so it is fixed, thanx for the info where to look.

Viewing 14 posts - 1 through 14 (of 14 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded