Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 1 Support › No text on iOS

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4359

    Philipp

    We have a problem that all our TextViews do not show any Text on iOS. The text works fine on Mac and Android and we have not really changed anything. Do you have any suggestions?

    #4360

    Philipp

    We have achieved a little something with using a FontLoader like this:
    FontLoader {
    id: fontLoader
    source: "fonts/Noteworthy.ttc"
    }

    Text {
    id: buttonText
    font.pointSize: 25
    font.family: fontLoader.name
    font.bold: true
    anchors.horizontalCenter: parent.horizontalCenter
    //anchors.verticalCenter: parent.verticalCenter
    textFormat: Text.PlainText
    }

    At least we see now the first letters of a word. Meaning the label “New Game” is displayed as “New”, or “Sound off” is displayed as “Sound. It does not take the space as indicator, because “Resume” is displayed as “Resum”

    We have absolutely no idea how to fix this. Again only appears on iOS!

    #4362

    Alex
    Felgo Team

    Have you already tried loading another font instead of¬†Noteworthy.ttc? We do support single ttf fonts only in general, we are however currently testing if the ttc font can be the source of the problem…

    Cheers,
    Alex

    #4365

    Peter

    We first tried it with Anton.ttf then with the Noteworthy.ttc and it didn’t work. However we changed it to Chalkduster.ttf font again and now it seems to work again. So I’m pretty sure it was the ttc!

    Thanks

    #4366

    Alex
    Felgo Team

    I see, if you want to use the font you can also try to convert the font to a ttf, for example with this online tool: http://www.freefontconverter.com

    Cheers,
    Alex

Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.