Forums

OverviewFelgo 2 Support (Qt 5) › Please confirm Google Cloud Messaging is still a valid plugin

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23659

    jrrobles79

    Please can someone confirm if this plugin still works, it dosen’t appear on the Felgo plugins on my QT Creator, and the documentation is not updated, also I get this messages on my debug:

     

    Warning: Plugin “VPlay.plugins.gcm” disabled: Native frameworks not found

     

    or

     

    LOGCAT: W GCM : GCM SDK is deprecated, com.my.project should update to use FCM

     

    Also in the Demo Project all that refers to this is commented or disabled.

     

    Already tryed to ask this question on the Plugins forum but not answer, I need an answer to look for a solution, because I haven’t been able to make it work.

     

     

     

    #23660

    Alex
    Felgo Team

    Hi,

    The plugin is still active and working for existing projects. Because Google moved from GCM to FCM (which is “GCM SDK is deprecated, com.my.project should update to use FCM”), we do not list it in the Qt Creator at the moment and work on porting the plugin to Firebase Push.

    Until we finished with that, we recommend to use OneSignal over GCM, it uses GCM in the background but provides a much better Web Dashboard on top of it.

    For the “Native frameworks not found” error: Did you follow the plugin integration guide, i.e. adding the implementation line to your gradle file and rebuilding the project?

    Best,

    Alex

Viewing 2 posts - 1 through 2 (of 2 total)

RSS feed for this thread

You must be logged in to reply to this topic.