OverviewFelgo Installation › proxy settings

Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #15866


    I’ve installed latest Felgo SDK and run QTCreator. But I can’t login to my Felgo account cause my PC is under the proxy. There are no proxy settings in Options. How to use SDK in this case?




    There’s a workaround for that.

    • Start the MaintenanceTool.exe (it is inside your Felgo installation folder), and select “Settings”.
    • Enter your Proxy Settings and click “OK”
    • Select “Update Components” and click “Next”.
    • The MaintenanceTool will now prompt you for username and password. Use your Felgo credentials to log in. Afterwards, run the update, which should download your Felgo license file.

    After this procedure, you should be logged in in Qt Creator too. Let me know if you have any issues with that!


    Lorenz from Felgo





    Thanks for your help. But still no success here ((.

    I’ve started tool and set proxy host and port. Now I have “Preparing meta info download…” forever. I think, this happens because our proxy use Kerberos protocol and requires authorization.




    Then I am afraid you are affected by this Qt Bug:

    There are some hints on that page. You could try running the MaintenanceTool with from the command line with the –proxy parameter

    If that still doesn’t work, send us an e-mail to our support adress, there might be one more option left to get this working for you.

    Good Luck!






    Very strange behavior. I’ve started MaintenanceTool from command line with “–proxy” arg and select “Update components”. I’ve received credentials request and tool say and there is nothing to update after some check. Then I’ve run QtCreator and it still require login. I tried to remove some component using MT again, but I can’t install it back, it just disappear from the list. So my install becomes corrupted.


    I’ve removed SDK completely and install it again. But now MaintenanceTool –proxy doesn’t work at all ((. It try to connect for some time and then crash. Is there any way to download license file manually and put is somewhere?



    Please send us an e-mail to and we will send you the license files via mail.

    All the best,





    MaintenanceTool works with “No proxy” setting even if run not from command line. But QtCreator can’t login. Magic.



    Hi Anatoliy,

    We just came back to you via mail.

    All the best,




    Thanks a lot. Received license. Everything works fine now.

Viewing 10 posts - 1 through 10 (of 10 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
create apps
create games
cross platform
native performance
3rd party services
game network
level editor
easiest to learn
biggest time saving
best support