Forums

OverviewFelgo Installation › 'QApplication' file not found in iOS build

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16470

    Wojciech

    I have passed trough installation on macbook, I have iOS version of qt in maintanance tools installed.

    When I build for desktop: my app work. But when I build for connectedn iPhone I get message as QApplication is not visible. It just stops on the first qt library, in Felgo samples it is VPApplications (also not found).

    When I open procects in XCode, I got the same messages, to there must be wrong with my QT installation for iOS.

    I have XCode 8, I have enrolled in Apple developer program (I have no problems with signing). I use newest pack of VPlay, with Qt 5.8.

    What should I do now?

     

    #16484

    Lorenz

    Hi Wojciech,

    First I’d like to check if the Felgo library was properly installed. Can you check that <YourFelgoSDK>/5.8/ios/lib/libVPlay.a exists?

    Secondly, are you sure that you selected the correct kit? Also, did you try to build an app for the iOS Simulator?

    Also, have you already tried to deploy an empty Qt application (without Felgo) to your iOS device, and does that work?

    Best,

    Lorenz

    #16494

    Wojciech
    1. No, the file is only in clang_64 folder tree, not in ios path. It looks like ios libs have only part of files.. How to fix it?
    2. Yes, for iOS Simulator I got similar errors.
    3. Yes, it works.

    So my installation seems to be not full, but I have done in by instructions step by step.

    #16495

    Wojciech

    Probably it is due to the order of my installation: first I installed V-play, next I addes iOS tree.

    Shoud I copy some files manually? Or uninstall and install everything again?

     

    #16496

    Lorenz

    Hi Wojciech,

    Either way. the iOS libraries should have been installed automatically. Are you using the Felgo MaintenanceTool or the one provided by Qt?

    I recommend you to uninstall Felgo using the Maintenance Tool (Add or remove components -> Uncheck Felgo) and then install it again.

    If that doesn’t solve the error, let us know!

    Cheers,

    Lorenz

     

    #16497

    Wojciech

    I have done it, but it has not solved the issue.

    libvplay.a is still not available in ios lib folders. In includes lib also vplay is not available. Is there everything OK with v-play installation pack? Mayby there is some files missing there?

    Regards,

    Wojciech

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support