Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 3 Support (Qt 5) › Qt53DCore

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #13048



    since the upgrade to the newest SDK version (VPlay 2.8 / Qt 5.6) I have problem with running *.exe files outside of the QtCreator. I got the error:

    Cannot find the entry point to procedure: Qt3DCore QEntity addComponent in Qt53DCore.dll.

    I am using the MinGW 4.9.2 compiler on Windows 7 x64. Are you familiar with this issue?


    Best regards,

    Paweł Krakowiak


    Felgo Team

    Hi Pawel!

    Are you using the 3D features by Qt / Felgo?

    Qt 3D is still a technology preview and from Qt 5.5 to Qt 5.6 there were some major changes to the 3D components by Qt.
    We did not yet finish updating our Visual 3D Components to be compatible with these changes – we hope to be able to include a fix in the next update.




    Hi Günther,

    I’ve tried with an empty project and got the same error.


    Felgo Team

    Did you add all required libraries to be able to run the app standalone by using the Windows Deployment Tool by Qt?
    You can have a look at this post to see how it should be used.
    If you still have troubles and you are not using the 3D features, you can try  to remove the Qt 3D dependencies that Felgo adds:
    – open the file vplay.prf in the <VPlayInstallDir>/5.6/mingw49_32/mkspecs/features directory
    – in line 7: Remove or comment the flag CONFIG += vplay3d_support
    e.g. #CONFIG += vplay3d_support





    Using windeployqt did the trick. Thanks Günther! 🙂


    However I’m wondering what is wrong in using other libraries – which leads to such misleading error. E.g. I was trying to run my app with Felgo sample launchers’ libs. It was always a “successfull point of last resistance” till Qt5.6. I undertand that upgrade to the new Felgo/Qt version does not mean upgrade of launchers’ libs, but what could be wrong in them that they point to Qt53DCore.dll and those from MinGW not?


    Ps. Thanks again Günther, you saved mine and my friends’ LD35 entries 🙂


    Regards, Paweł


    Felgo Team

    Adding the required libraries is always necessary for the application to be able to run standalone.

    As far as I know we build the current Sample Launcher that is shipped with the SDK with the MSVC compiler, which might use some different dll’s than the MinGW version. I guess that the update to Qt 5.6 included some changes in the required libs for the compilers.

    Cheers, Günther


Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded