Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › SoundEffectVPlay – Volume problems

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9057

    Matt

    Getting problems with multiple sounds being played at different volumes, if a sound currently play is at a lower volume (say 0.3) and another different sound is triggered at a higher volume then both sounds continue playing at that higher volume. Is this a bug? or am I missing something?

     

    They are separate sound effects so I don’t see why all effects should use same volume, makes layering a games sound very difficult.

    i.e. we have background noise for engines, environment but need louder more obvious sounds for gun fire and explosions.

    #9058

    Alex
    Felgo Team

    Hi,

    on Windows there is currently only one global volume, which is more or less a bug yes. This is supposed to be fixed with the next Qt version. However it works on iOS and Android, so if you are targeting mobile you are already good to go.

    Also if you do not need to modify the volume dynamically at runtime, you could change the volume with an audio editor and use those files in your project instead.

    I hope this helps.

    Cheers,
    Alex

    #9059

    Matt

    I noticed it was fine when testing on an Android device last night, if it’s OK on iOS too? then windows desktop doesn’t matter so much.

    Didn’t think of editing the sound file! good idea – when it comes to windows at least that’s an option.

     

    Cheers,

    Matt

    #9060

    Alex
    Felgo Team

    Yes, the problem only occurs on Windows.

    Cheers,
    Alex

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded