Find the Best Demos and Examples

Check out this quick tour to find the best demos and examples for you, and to see how the Felgo SDK can help you to develop your next app or game!

Forums

OverviewFelgo 2 Support (Qt 5) › Strange error + Custom Live Client Not Working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23770

    Felgo User

    Earlier this week, I downloaded Felgo. before this I already was using the latest version of Qt and Qt Creator and had it on my laptop. When I tried to run the default project for the first time using the green play button, I got the following error. I cannot seem to add a picture to this post but the error says                    “[Makefile.Debug:117:copy_desktop_qt_ssl_windows5] Error 1”. I get this error whenever I try to build and run it normally (with MinGW kit). However, the project seems to run normally when I run the live button farther above.

    Later, I was build and Qt Project with Felgo and realized I needed a new live client for my custom c++ modules to work in qml. I exactly followed the directions on this website: https://blog.felgo.com/updates/release-2-16-1-live-code-reloading-with-custom-c-and-native-code-for-qt. However, it says I now need to run with the normal green play button, which doesn’t work due to the error. If I run it with the live button, the original error before I followed those directions occurs. Does anyone have any solutions to any of these problems (not sure if they are directly connected)?

    #23787

    Alex
    Felgo Team

    Hi,

    could you post the full output of the build log output, or send it to support@felgo.com

    Usually this error can appear if you have other MinGW installations present in your Windows PATH environment variables.

    Best,
    Alex

    #23792

    Felgo User

    Here is the full compile log:

    08:23:35: Running steps for project FelgoCompetitiveBallTryOne…

    08:23:35: Configuration unchanged, skipping qmake step.

    08:23:35: Starting: “C:\Felgo\Tools\mingw730_32\bin\mingw32-make.exe” -j8

    C:/Felgo/Tools/mingw730_32/bin/mingw32-make -f Makefile.Debug

    mingw32-make[1]: Entering directory ‘C:/Users/arjun/Documents/build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug’

    cp -f C:\Felgo\Felgo\mingw_32\lib\vcruntime140.dll “C:\Users\arjun\Documents\build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug\debug”

    cp -f C:\Felgo\Felgo\mingw_32\lib\libcrypto-1_1.dll “C:\Users\arjun\Documents\build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug\debug ”

    cp -f C:\Felgo\Felgo\mingw_32\lib\libcrypto-1_1-x64.dll “C:\Users\arjun\Documents\build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug\debug”

    cp -f C:\Felgo\Felgo\mingw_32\lib\libssl-1_1.dll “C:\Users\arjun\Documents\build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug\debug”

    cp -f C:\Felgo\Felgo\mingw_32\lib\libssl-1_1-x64.dll “C:\Users\arjun\Documents\build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug\debug”

    Copying application data…

    Copying application data…

    cp: cannot stat ‘C:FelgoFelgomingw_32liblibssl-1_1.dll’: No such file or directory

    cp: cannot stat ‘C:FelgoFelgomingw_32liblibcrypto-1_1.dll’: No such file or directory

    cpcp: : cannot stat ‘C:FelgoFelgomingw_32liblibssl-1_1-x64.dll’cannot stat ‘C:FelgoFelgomingw_32libvcruntime140.dll’: : No such file or directoryNo such file or directory

    cp: cannot stat ‘C:FelgoFelgomingw_32liblibcrypto-1_1-x64.dll’: No such file or directory

    mingw32-make[1]: *** [Makefile.Debug:120: copy_desktop_qt_ssl_windows1] Error 1

    mingw32-make[1]: *** Waiting for unfinished jobs….

    mingw32-make[1]: *** [Makefile.Debug:126: copy_desktop_qt_ssl_windows3] Error 1

    mingw32-make[1]: *** [Makefile.Debug:123: copy_desktop_qt_ssl_windows2] Error 1

    mingw32-make[1]: *** [Makefile.Debug:117: copy_desktop_qt_ssl_windows5] Error 1

    mingw32-make[1]: *** [Makefile.Debug:129: copy_desktop_qt_ssl_windows4] Error 1

    mingw32-make[1]: Leaving directory ‘C:/Users/arjun/Documents/build-FelgoCompetitiveBallTryOne-Desktop_Qt_5_13_2_MinGW_32_bit-Debug’

    mingw32-make: *** [Makefile:38: debug] Error 2

    08:23:41: The process “C:\Felgo\Tools\mingw730_32\bin\mingw32-make.exe” exited with code 2.

    Error while building/deploying project FelgoCompetitiveBallTryOne (kit: Desktop Qt 5.13.2 MinGW 32-bit)

    When executing step “Make”

    08:23:41: Elapsed time: 00:06.

     

    The general message area says…

    2020-09-11T07:46:34 Clang Code Model: Error: The clangbackend executable “C:\Felgo\Tools\QtCreator\bin\clangbackend.exe” could not be started (timeout after 10000ms).

    Project MESSAGE: This project is using private headers and will therefore be tied to this specific Qt module build version.

    Project MESSAGE: Running this project against other versions of the Qt modules may crash at any arbitrary point.

    Project MESSAGE: This is not a bug, but a result of using Qt internals. You have been warned!

     

    And the issues area says…

    [Makefile.Debug:117:copy_desktop_qt_ssl_windows5] Error 1

     

    You also mentioned that this happens if there are other MinGW installations. I have installed MinGW separately when working with another IDE and I also have a seperate Qt installation without Felgo with MinGW. Is there anyway to fix this problem?

    #23794

    Alex
    Felgo Team

    Hi,

    can you try removing to path to the separate MinGW installation from the PATH environment variable and check if it builds correctly then? Ideally restart Qt Creator after removing the path, and perform a clean and qmake step before building.

    Best,
    Alex

    #23796

    Felgo User

    Hello,

    I deleted it from my path but I still seem to get the same errors as above. I am not sure if I did it incorrectly or something. It doesn’t seem like I can send screenshots in this answer!

     

    Thanks,

    Arjun

    #23804

    Gregor
    Felgo Team

    Hello Arjun,

    please reboot your computer after changing the PATH in the system settings, for changes to take fully affect.

    If the issue is still present for you, please send us a mail to support@felgo.com  – referring to this thread.
    Please include:

    — Qt Creator Log output

    — Screenshot of your Windows System PATH configuration (the dialog should look similar to this https://www.architectryan.com/static/edit_path_variable-42eb044d39582f04f1f213e17e4fcb30-c532b.png ). Please scroll down and attach additional screenshots if there is more.
    — Screenshot of your Windows User PATH configuration (in the settings window you should see have a option for PATH on top and bottom, one is for system, the other for the current logged in user.

     

    Best,
    Gregor from Felgo

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.