Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 4 Support (Qt 6) › Trying Felgo 4 not working for Android

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #24907



    I don’t know if I am in the good forum, but I don’t see any Felgo 4 specific forum yet…

    My problem isn’t when compiling, this step is all good for all targets. When I try launching the app on Android I got this error :

    E AndroidRuntime: FATAL EXCEPTION: qtMainLoopThread
    E AndroidRuntime: Process: com.***.***.***, PID: 12317
    E AndroidRuntime: java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__emutls_get_address" referenced by "/data/app/~~8HLoLLq_ofnP--DWo_UZ_g==/com.***.***.***-aJZ31QEEviR55slRRgHjKw==/lib/arm64/libQt6Core_arm64-v8a.so"...
    E AndroidRuntime: 	at java.lang.Runtime.load0(Runtime.java:929)
    E AndroidRuntime: 	at java.lang.System.load(System.java:1625)
    E AndroidRuntime: 	at org.qtproject.qt.android.QtNative$2.run(QtNative.java:432)
    E AndroidRuntime: 	at org.qtproject.qt.android.QtThread$2.run(QtThread.java:51)
    E AndroidRuntime: 	at org.qtproject.qt.android.QtThread$1.run(QtThread.java:25)
    E AndroidRuntime: 	at java.lang.Thread.run(Thread.java:1012)

    I have no problems running on iOS and Windows. It’s Android specific, I tried arm64-v8a and armeabi-v7a, different devices and different version of SDK and NDK…

    Maybe you can give me a working build configuration, so that I can check if something went wrong.

    I’m using the default template for todo app, so I think the gradle config and AndroidManifest are okay.




    Felgo Team

    Hi Allen,

    this is likely related to the Android NDK. Felgo 4 now requires NDK 23.1. (we missed to update this version in the Android deployment guide). Please install this version and then:

    • make sure to enable the correct one as default in the QtC Android settings
    • After changing the default, also use CMake “re-configure with initial parameters” in project settings (or remove build folder and CMakeLists.user.txt to make sure you get a fresh/clean setup when opening the project again)





    Perfect, it works now. I hadn’t tried this version of NDK.


Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded