Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Windows deployment

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #9004

    Heini

    Hi,

    I am trying to set up a deployment directory containing all necessary files to open my VPlay game on a (non development) windows PC. I compiled my game with the VS2010 compiler.

    In my folder are the following files: libEGL.dll, libGlesv2.dll, d3dcompiler_43.dll, icudt53.dll, icuin53.dll, icuuc53.dll, msvcp100.dll, msvcr100.dll, the windows plugin and a lot of Qt dll´s.

    The game is still not running on other machines, without prompting a message. So I wonder if there is any Felgo depending dll that I have to add too. If yes, where are they located?

    Thanks!

    Heini

    #9006

    Alex
    Felgo Team

    Hi Heini,

    we are using the windeployqt tool that comes with Qt to package Windows desktop applications.

    First you build your application in release mode with the Qt-Creator to generate the shadow build directory, then you use the windeployqt.exe of the same compiler to package your build, like this (command line):

    <Path to Qt>\5.4\<Your Compiler>\bin\windeployqt.exe –qmldir <Path to the Shadow Build>\qml <Path to the Shadow Build>\release

    Then you should be ready to go. Let me know if this worked for you!

    Cheers,
    Alex

    • This reply was modified 7 years, 1 month ago by  Alex.
    • This reply was modified 7 years, 1 month ago by  Alex.
    #9011

    Heini

    Hi Alex,

    it did not work – says it can not find the ICU files, but they are directly in the same folder as the windeployqt.exe. Maybe I should try to set the qt path system variable, but how should I name it? QT_PATH? And should it point to the qt mainfolder or to the bin folder?

    Thanks,

    Heini

    #9013

    Heini

    Hi,

    after editing the PATH variable, it is working now! Thanks for the hint!

     

    Heini

    #23931

    Florian

    Hi,

    I am building a windows app with Felgo. I try to deploy this app on another computer without Qt installed.

    My application is build with mingw32 installed in Flego. As you say previously, i run this command :

    C:\Felgo\Felgo\mingw_32\bin\windeployqt.exe –qmldir C:\Soft\IBM_CLAVIER\SoftPcQt\build-PeakCanApp-Desktop_Qt_5_13_2_MinGW_32_bit-Release\qml C:\Soft\IBM_CLAVIER\SoftPcQt\build-PeakCanApp-Desktop_Qt_5_13_2_MinGW_32_bit-Release\release

    Then i copy my build-PeakCanApp-Desktop_Qt_5_13_2_MinGW_32_bit-Release\release folder on the new PC and application don’t start.

    I have no error message.

    Have you got an idea ?

    #23932

    Alex
    Felgo Team

    Hi,

    you are probably still missing a dependency then. Can you try to paste your exe file to <Path to your Felgo installation>/Felgo/FelgoLive (that’s where the Felgo Live Client and Server executables are) and see if it starts launches from there? Then you could compare all the dependencies that are in place, if something is missing for your application. Also check if your assets are deployed correctly.

    Best,
    Alex

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded