Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business

Forums

OverviewFelgo 2 Support (Qt 5) › Android build failed

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #21127

    Jean-Baptiste

    I try both on Windows and Linux to build Android application with fresh Felgo installation.

    For that i downloads last version, installs it, and restart maintenance tool to add Android (armv7) component.

    I configure QtCreator with last version of JDK (1.8.0_201), Android SDK from last version of Android Studio and Android NDK r18b

    Then i try to build freshly created “Basic Application” for Android, but the build fail with follwing error message:

    “The installed SDK tools version (26.1.1) does not include Gradle scripts. The minimum Qt version required for Gradle build to work is 5.9.0/5.6.3”

     

    I try to install another version of SDK platform from QtCreator (Android 6.0), but there is no changes.

    #21130

    Günther
    Felgo Team

    Hi Jean,

    as Qt Creator utilized your installed Android Tools for building, there can be compatibility issues with certain Android SDK or NDK versions. Specifically, the latest Android NDK version 18 does not yet work correctly as far as we know. Please remove your current NDK installation and install an earlier version. For example an Android NDK version r10e up to version 17 should work fine. You get them from the NDK archives: https://developer.android.com/ndk/downloads/older_releases

    In case you suffer from a “No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android” error, you can find more information and solution steps here: https://felgo.com/developers/forums/t/necessary-android-sdk-and-ndk-versions#post-20818

    Best,
    Günther

    #24011

    Ian

    I am writing this reply for anyone else that faces this problem in the future.

    As mentioned above, the error in question is:

    “The installed SDK tools version (26.1.1) does not include Gradle scripts. The minimum Qt version required for Gradle build to work is 5.9.0/5.6.3”

    This error is completely unhelpful, the android sdk as of writing this does not contain any package called “SDK tools” or even “tools”, furthermore, no existing packages have version number 26.1.1. The only useful piece of information that exists in the error is that Gradle is missing.

    In my particular case I also noted that even after setting up all the necessary paths in QT i.e SDK, NDK, JDK, no kits were available for android.

    The solution was to install additional components for android using the QtMaintenace tool. In my windows box, I found it at C:\Felgo\MaintenanceTool.exe.

    After running the MaintenanceTool, select Add or remove component then click next. In the next window, select all the android components and click Next. This will install android kits and on your first build, Gradle will be downloaded.

     

    Hopefully this has saved someone a very painful day.

    Cheers.

Viewing 3 posts - 1 through 3 (of 3 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded