Learn what Felgo offers to help your business succeed. Start your free evaluation today! Felgo for Your Business


OverviewFelgo 4 Support (Qt 6) › Android device set-up

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #25183



    I’ve followed the guide and installed JDK, Android NDK, Android SDK plus all the other stuff including the obsolete Android SDK Tools but Qt still reports the following errors (Devices->Android):
    X SDK Manager runs
    X Platform SDK installed
    X All essential packages installed for all installed Qt versions.

    If I select SDK Manager no packages are listed. The Android SDK location matches the one in Android Studio.

    I’ve also tried installing earlier versions of the Android SDK Command Line tools since that worked for someone else but it hasn’t helped me. I’ve even uninstalled everything, including the earlier Felgo / Qt and reinstalled everything but still no luck.
    Any ideas?



    Further to this, I installed everything in the SDK Tools section (including obsolete) but still no luck.



    If I run the SDK manager from QtCreator->Preferences->Devices->Android it’s empty. However, when I click ‘update installed’ it has a java.lang exception “SdkManagerCli has been compiled by a more recent version of the Java Runtime (class file version 61,0), this version of the Java Runtime only recognises class file versions up to 55).
    So I removed the Android SDK Command Line Tools so I just have version 8.0 installed (since that worked for someone else). Now I’m getting java.lang.ClassNotFoundException when doing the ‘update installed’.

    I’m going to try each version of the command line tools and see what happens.



    That didn’t work but I noticed if I go into kits Qt hasn’t auto-detected any Android ones, only Desktop. Then if I look at Qt Versions all the Android ones have got errors ‘failed to detect the ABIs used by the Qt version. Checl the settings in Devices -> Android for errors’.

    I’m going to uninstall everything and start yet again. I didn’t want to do any dev this week anyway…




    I’ve even tried installed the NDK alongside the SDK using Android Studio, still nothing


    Felgo Team

    Hi Jon-Paul,

    Due to changes in how the Android SDK and tools operate, Qt Creator fails to correctly detect and use the latest version of the Android SDK command line tools.

    In addition to installing the correct SDK/NDK versions, please make sure to also install Android SDK Command Line Tools version 10.0 (the latest one is 11.0). Unfortunately, Qt Creator always uses the latest one, so it won’t detect the SDK correctly even when 10.0 is installed in addition. The best workaround to fix it is to go to the /cmdline-tools folder of the SDK installation, and rename the folders so that “latest” contains the 10.0 tools. This way, Qt Creator will use the 10.0 command line tools and should be able to detect the SDK correctly.

    Let me know if this helps!





    I now have a bunch of ticks so the trick was renaming that folder.


    For anyone else, I had the following installed before renaming the folder:
    Felgo 4 / Qt6

    Android Studio Hedgehog

    Android SDK Platforms 13 and 14

    Android SDK Build Tools 34.0.0

    Android NDK 26.1.10909125 (side by side in Android Studio)

    Android SDK Command Line Tools 10.0
    Android Emultaor

    Android SDK Platform Tools

    Google Play Services

    Google USB Driver



    When you go into QtCreator->Preferences->Devices->Android, it will prompt you to install more stuff. The following gets installed:
    Android SDK Platform 12 (although this isn’t supported by Google anymore)

    Android SDK Build Tools 31.0.0

    Android NDK 25.1.8937393

    Android NDK 26.1.10909125 and 23.1.7779620

    Android SDK Command Line Tools 11.0 (latest)


    I’m not sure whether I can remove those but at the moment QtCreator thinks all the Android settings are fine so I’ll leave it for now

Viewing 8 posts - 1 through 8 (of 8 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Qt_Technology_Partner_RGB_475 Qt_Service_Partner_RGB_475_padded