Forums

OverviewFelgo Installation › Android Simulator

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #21427

    Paolo Mazzon

    I am trying to install the Android simulator but it gives me this error

     

    #21431

    Paolo Mazzon
    #21432

    Günther
    Felgo Team

    Hi Paolo,

    Felgo currently comes with Qt 5.11.1. As far as I know, the Android NDK version 19 is not compatible yet.

    Best,
    Günther from Felgo

     

    #21440

    Paolo Mazzon

    Have a nice day I need to know the latest working versions On felgo to make my app go on android please:
    1) Java version
    2) Sdk tools
    3) Ndk tools

    I’m trying all of them but they don’t work, I’m just wanting to continue with felgo, you need to update the guides.

    Thank you

    #21443

    Günther
    Felgo Team
    #21445

    Paolo Mazzon

    I did as you said the simulators work but there is always the usual problem, I tried also with the examples but they all give the same error also changing the Gradle with

    classpath "com.android.tools.build:gradle:3.2.1"

    but not work.

     

    21:30:27: Running steps for project ClientPaolo1...
    21:30:27: Configuration unchanged, skipping qmake step.
    21:30:27: Starting: "D:\android-ndk-r14\prebuilt\windows-x86_64\bin\make.exe" 
    make: Nothing to be done for `first'.
    21:30:28: The process "D:\android-ndk-r14\prebuilt\windows-x86_64\bin\make.exe" exited normally.
    21:30:28: Removing directory D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build/assets
    21:30:29: Removing directory D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build/libs
    21:30:29: Starting: "D:\android-ndk-r14\prebuilt\windows-x86_64\bin\make.exe" "INSTALL_ROOT=D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build" install
    D:\GoogleDrive\c++\QT\FelgoCasa\Felgo\android_x86\bin\qmake.exe -install qinstall D:\GoogleDrive\c++\QT\ClientPaolo1\qml D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build\assets\qml
    D:\GoogleDrive\c++\QT\FelgoCasa\Felgo\android_x86\bin\qmake.exe -install qinstall D:\GoogleDrive\c++\QT\ClientPaolo1\assets D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build\assets\assets
    D:\GoogleDrive\c++\QT\FelgoCasa\Felgo\android_x86\bin\qmake.exe -install qinstall -exe libClientPaolo1.so D:\GoogleDrive\c++\QT\build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug\android-build\libs\x86\libClientPaolo1.so
    21:30:30: The process "D:\android-ndk-r14\prebuilt\windows-x86_64\bin\make.exe" exited normally.
    21:30:30: Starting: "D:\GoogleDrive\c++\QT\FelgoCasa\Felgo\android_x86\bin\androiddeployqt.exe" --input D:/GoogleDrive/c++/QT/build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug/android-libClientPaolo1.so-deployment-settings.json --output D:/GoogleDrive/c++/QT/build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug/android-build --android-platform android-28 --jdk "C:/Program Files/Java/jdk1.8.0_201" --gradle
    Generating Android Package
      Input file: D:/GoogleDrive/c++/QT/build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug/android-libClientPaolo1.so-deployment-settings.json
      Output directory: D:/GoogleDrive/c++/QT/build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug/android-build/
      Application binary: D:/GoogleDrive/c++/QT/build-ClientPaolo1-Android_for_x86_GCC_4_9_Qt_5_11_1_Android_x86_Felgo_0e8f72-Debug/libClientPaolo1.so
      Android build platform: android-28
      Install to device: No
      -- Skipping D:/GoogleDrive/c++/QT/FelgoCasa/Felgo/android_x86/plugins/iconengines/libqsvgicon.so. It has unmet dependencies: lib/libQt5Svg.so.
      -- Skipping D:/GoogleDrive/c++/QT/FelgoCasa/Felgo/android_x86/plugins/imageformats/libqsvg.so. It has unmet dependencies: lib/libQt5Svg.so.
      -- Skipping D:/GoogleDrive/c++/QT/FelgoCasa/Felgo/android_x86/plugins/position/libqtposition_serialnmea.so. It has unmet dependencies: lib/libQt5SerialPort.so.
    To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/3.4/userguide/gradle_daemon.html.
    Daemon will be stopped at the end of the build stopping after processing
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem occurred configuring root project 'android-build'.
    > Could not resolve all dependencies for configuration ':classpath'.
       > Could not find com.android.tools.build:gradle:3.2.0.
         Searched in the following locations:
             https://jcenter.bintray.com/com/android/tools/build/gradle/3.2.0/gradle-3.2.0.pom
             https://jcenter.bintray.com/com/android/tools/build/gradle/3.2.0/gradle-3.2.0.jar
         Required by:
             project :
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    
    Total time: 15.81 secs
    Warning: QML import could not be resolved in any of the import paths: com.yourcompany.wizardEVAP
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Material.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Fusion.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Imagine.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Universal.impl
    Building the android package failed!
      -- For more information, run this command with --verbose.
    21:30:59: The process "D:\GoogleDrive\c++\QT\FelgoCasa\Felgo\android_x86\bin\androiddeployqt.exe" exited with code 14.
    Error while building/deploying project ClientPaolo1 (kit: Android for x86 (GCC 4.9, Qt 5.11.1 Android x86 Felgo))
    When executing step "Build Android APK"
    21:30:59: Elapsed time: 00:32.

     

    #21477

    Paolo Mazzon

    I don’t understand I have the same configuration on the mac and it works them. now i try to install everything on the same disk

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support