Forums

OverviewFelgo 2 Support (Qt 5) › Installation Issues Felgo Qt 5

Viewing 14 posts - 91 through 104 (of 104 total)
  • Author
    Posts
  • #17856

    Günther
    Felgo Team

    Hi Bas!

    Did you install Felgo / Qt Creator with your admin user account?
    Maybe Qt Creator now does not have read/write access to some installed files when running Qt Creator without admin rights?

    Best,
    Günther

    #17857

    Bas

    hi Gunther,

     

    I installed with my account with admin rights yes.

    but I am not shure why this happened, but I think it has todo with my OS and not with V-play/QT.

    it is working now, I told the qtcreator exe to run as admin.

    thnax,

    Bas

    #19394

    Pat

    Installed on Windows10 using the downloaded installer and tried to load the CarChallenge3D example then got:

     

    QQmlApplicationEngine failed to load component

    file:///C:/FelgoSDK/Examples/Felgo/demos/build-CarChallenge3D-V_Play_Desktop_Qt_5_10_1_MinGW-Debug/qml/CarChallenge3DMain.qml:79 Type Scene3DVPlay unavailable

    qrc:///qml/VPlay/3d/Scene3DVPlay.qml:4 plugin cannot be loaded for module “QtQuick.Scene3D”: Cannot load library C:\FelgoSDK\Felgo\mingw_32\qml\QtQuick\Scene3D\qtquickscene3dplugin.dll: The specified module could not be found.

    The program has unexpectedly finished.

    The process was ended forcefully.

    C:/FelgoSDK/Examples/Felgo/demos/build-CarChallenge3D-V_Play_Desktop_Qt_5_10_1_MinGW-Debug/debug/CarChallenge3D.exe crashed.

    #19403

    Christian
    Felgo Team

    Hi Pat,

    the CarChallenge demo was built on the tech preview version of the Qt3D APIs. As these got changed internally, we did not add them to Felgo so far as we did not update them yet. This is also why the CarChallenge3D demo is currently not running. We decided to keep this demo in the Felgo installer though, because it shows how you can use 2D physics and the same game API with both 2D and 3D rendering. You can find the blog post with a video about it here:

    https://felgo.com/qt3d/qt-3d-game-engine-with-qt-5-5-and-v-play-game-engine

     

    If you’d like to add 3D rendering to your Felgo apps or games, you can either add the Qt3D components yourself, or contact us for assistance here to cover this with a support hour package.

    Cheers, Chris

    #20617

    Asaad

    Hello,

    I installed Felgo yesterday in fresh Windows 10 and I had no Kits and for some reason the UI when start show some tabs about tutorial and then switch back to the old UI and give me an error ( too many files opened ). Today I switched to Linux since it is my main operating system and the same thing happen. also happened when I upgrade Felgo in my old laptop.

     

    can any one tell me what to do. Please.

    #20619

    Bas

    So it is the same project you try to run on different machines with different OS?

    #20620

    Asaad

    No.

    I had a laptop with Arch Linux and I was using Felgo the previous version and I upgrade to the new version ( the current version ). The kits (arm, 86) dispersed and some UI problems. I received my new laptop and it has windows 10 preinstalled and I tried Felgo in windows and it faces the same issues. I format my laptop and installed arch and installed Felgo. But still the same problems.

     

    The link bellow a screen shot when I run Qt:

    Stuck for a 2 second and then the next one

    The next screen shot after it stuck and give me before an error (too many files opened)

    this UI stay

     

    The other problem is with kits and as you can see it does not show any installed kits except the Desktop.

    the Kits

     

     

    I hope this clear every thing and I hope some one in the Felgo team help out.

    #20706

    Alex
    Felgo Team

    Hi,

    can you check the Android settings in Qt Creator (Tools > Options > Devices > Android) to see if there is a potential issue? What SDK and NDK version are you using?

    For the UI issue, are you stuck in the welcome screen and cannot open/edit any projects? Does it get responsive again after waiting some seconds?

    Cheers,
    Alex

    #21502

    Felgo User

    Hello,

    I am trying to add felgo to my existing Qt installation on windows using the maintenance tool, but after i add the repo “https://sdk.felgo.com/2/windows“ to my user defined repos it does not show up in the options to download, and after i test the repo in settings i get the error ” Cannot open Updates.xml for reading: No file name specified

    #21511

    Günther
    Felgo Team

    Hi,

    in general, we recommend to use the installer to install Felgo with all tools and libraries. It is also possible to have Felgo installed in addition to other Qt installations, which makes maintenance a little easier. Felgo is compatible with a certain Qt and Qt Creator version, and with the default installer you directly get the right versions and always have a clean and correct installation of Felgo + Qt.

    About your question:
    I guess you had a look at the blog post here: https://felgo.com/cross-platform-development/how-to-add-felgo-to-your-qt-mobile-app
    The post wrongly states https://sdk.felgo.com/2/windows, where actually https://sdk.v-play.net/2/windows should be used. The description in the online docs states the correct repository: https://felgo.com/doc/felgo-installation/#add-felgo-to-existing-qt-installation

    Best,
    Günther

     

    #21673

    Konstantin

    Hi, I am facing with error on my Kubuntu 19.04

    web sites in Chrome works fine.

    It is caused by ssl error obviously. How can I diagnoce it and fix?

    1

    #21695

    Alex
    Felgo Team
    #21916

    Berka Frenfert

    I had latest QT and Creator installed but M16 error did not let me continue learning Felgo. I removed the latest and now looking for Qt 5.4.0 and QtCreator 3.3.0 because M16 error is a bug. I dont know how older version is stable but latest has some something wrong with it. Please take a look at stackoverflow https://stackoverflow.com/questions/28899984/qt-invalid-property-name-x-m16-for-button

    I have tried all other solutions given by stackoverflow and i was able to supress M16 error. i think i should go for the stable and leave the latest for others to fix.

    Now i need the url where i can get Qt 5.4.0 and QtCreator 3.3.0

     

    Can someone help me?

    #21917

    Berka Frenfert
Viewing 14 posts - 91 through 104 (of 104 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support